Find the perfect San Francisco real estate agent
Page 1 of 2 12 LastLast
Results 1 to 20 of 25

Thread: Evo 8 won't start on me anymore!

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Evo 8 won't start on me anymore!

    Alrite so I'm hoping you guys can guide me in this or had the same trouble as I am currently having. My at died on me and never turned back on as I exited the highway. Got towed home and checked the car I couldn't find any other solution on why it was working I was gonna get the fuel pump but I hear it pumping and I was on a full tank so I didn't wanna check it. I moved up to my spark plugs and found out the my spark plugs where good I had a spare good spark plug and noticed that my coil pack for spark plug 2&3 where not sparking so I though it was the coil pack, as I swapped the coil pack to where the 1&4 where I saw that my coil pack was sparking now. So the connection to my coil pack for 2&3 spark plug is bad?? Not the best person when it comes to wiring so I've been breaking my head all these days trying to find out what's wrong and researching but still no luck! Help!! Haha

  2. #2
    Junior Moderator


    evobros's Avatar
    Join Date
    May 2008
    Posts
    4,506
    Cars
    Evo 8/9
    Try a buddies coil packs.
    Pictures on all for sale/for trade threads is being enforced!

  3. #3
    Yea a buddy offered me some already but he gets back on Monday so I'll have to see if anything that's the problem cause the coil pack for 1&4 don't work on that connection either.

  4. #4
    Pokemon Master kambodianboi's Avatar
    Join Date
    May 2008
    Location
    Pallet Town, Kanto
    Posts
    6,346
    Cars
    Dodrio
    Does the car kinda starts up and dies? or just wont turn over?

    Waka waka - I'm a slowpoke
    Doc Mosh #1 fan boy

  5. #5
    Evo Specialist HMatt's Avatar
    Join Date
    Apr 2009
    Posts
    4,222
    Cars
    2005 AS Evo VIII MR, 2010 GG Outlander GT
    I had to read it twice. Auto correct kinda fucked you.Anyway, it's probably no the connector. If it's not following the coil pack, then it could be the transistor pack.
    "Many thanks to the Prius... For using less fuel so I have more to BURN!"
    --Me
    "I slick back my hair, you know the Devil's in there"
    --from Elephants by Them Crooked Vultures
    "I am a fever, I ain't born typical"
    --from U R A Fever by The Kills

    My Deliciously White Trash Website: www.yourtrailerparkisshowing.com You know you wanna click on it!

  6. #6
    Quote Originally Posted by HMatt View Post
    I had to read it twice. Auto correct kinda fucked you.Anyway, it's probably no the connector. If it's not following the coil pack, then it could be the transistor pack.
    Haha yea mybad man stupid iPhone I'll look into the transistor pack today man! Thanks

  7. #7
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    There isnt really a resistor pack or transistor box for the coils on the EVO. The transistors are built into the top of the coils. They are triggered directly by the ECU.

    Assuming that your listed trouble shooting process is correctly described, sounds like not the coils. So next to check is if any chimpanzees have been into your wiring to connect a jumper harness, digging for tach signals for turbo timers or meth injection... then one of the wires that trigger the coil could be jacked. Otherwise it could be something fried in the ECU. But on a nice unmolested stock car tht would be super rare.

    Mike W

  8. #8
    Evo Specialist HMatt's Avatar
    Join Date
    Apr 2009
    Posts
    4,222
    Cars
    2005 AS Evo VIII MR, 2010 GG Outlander GT
    Well... My bad... DSMer in me came out a little there.
    "Many thanks to the Prius... For using less fuel so I have more to BURN!"
    --Me
    "I slick back my hair, you know the Devil's in there"
    --from Elephants by Them Crooked Vultures
    "I am a fever, I ain't born typical"
    --from U R A Fever by The Kills

    My Deliciously White Trash Website: www.yourtrailerparkisshowing.com You know you wanna click on it!

  9. #9
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    Yep, DSM guys with this symptom go grab the connector on the transistor pack thingy on the intake manifold and wiggle the f**k out of it and clean the connectors.

    Mike W
    Last edited by Mike W; 10-02-2013 at 02:05 PM.

  10. #10
    well i bought a new crank shaft sensor, so ima see how that goes.

  11. #11
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    If you are getting any spark at all and the fuel pump turns on, injectors click... your crankshaft sensor is working fine.

    Only foreign objects kill crankshaft sensors. Something getting down in the timing belt area and whacking into it. Or your crank thrust bearing is dead and when you push on the clutch pedal it moves the crank sensor trigger plate into the sensor where it eventually saws through the sensor. But then you would get no spark at all. The ECU would not see RPM at all and would not turn on the fuel pump or the injectors either.

    Mike W

  12. #12
    Did you use a multimeter and check to make sure the battery is fully charged. 13.6v or something near there.
    Zhong Cheung | Angry Panda Racing
    2006 Mitsubishi Evo 9 | 470whp/410wtq on E85 | 2.3L RPM Buschur Racing | Hankook 285 TDs | KW V3s
    Fastest Limited/Mod Class Evo in Time Attack at WSIR (Big Willow) - 1:25.562
    2nd Fastest Limited/Mod Class Evo in Time Attack at BRP 13CW - 1:47.425

  13. #13
    Evo Specialist HMatt's Avatar
    Join Date
    Apr 2009
    Posts
    4,222
    Cars
    2005 AS Evo VIII MR, 2010 GG Outlander GT
    ^It wouldn't spark on one coil and not the other with low voltage.
    "Many thanks to the Prius... For using less fuel so I have more to BURN!"
    --Me
    "I slick back my hair, you know the Devil's in there"
    --from Elephants by Them Crooked Vultures
    "I am a fever, I ain't born typical"
    --from U R A Fever by The Kills

    My Deliciously White Trash Website: www.yourtrailerparkisshowing.com You know you wanna click on it!

  14. #14
    Not So Newbie
    Join Date
    Sep 2013
    Posts
    33
    Cars
    EVO 8
    hey there evo 8 guys, could you please tell me what is the test group number an Evo 8 should have under the hood, thanks

  15. #15
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    Shouldnt you be posting somewhere that you need a stock cat to buy or rent? :-)

    Mike W

  16. #16
    Not So Newbie
    Join Date
    Sep 2013
    Posts
    33
    Cars
    EVO 8

    not relly mike

    I first need to know the test group number, i have stock cat but I am not sure if it is the proper one to install onto an evo 8

  17. #17
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    EVO 8 cat has no O2 sensor bung hole in it. EVO 9 stock cat has an O2 sensor bung in it. Otherwise they are the same.

    If you ended up with an EVO 9 cat, just put a bung plug in the O2 sensor hole in it. If it bolts up and has a triangle shaped cross section, it is the stock cat. There are no other options. It does not matter what anything says under the hood.

    Mike W

  18. #18
    Not So Newbie
    Join Date
    Sep 2013
    Posts
    33
    Cars
    EVO 8
    3mtxv02.0gts thats the one I have

  19. #19
    SoCalEvo.net Shop


    Mike W's Avatar
    Join Date
    Dec 2003
    Location
    RRE
    Posts
    3,221
    A picture is worth a thousand jumbled letters and numbers.

    MikeW

  20. #20
    Not So Newbie
    Join Date
    Sep 2013
    Posts
    33
    Cars
    EVO 8
    too dark already, will do it take it tomarrow, but I actually think its OEM CAT for a 2003 Lancer oz rally, will it fit?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •