Find the perfect San Francisco real estate agent
Results 1 to 5 of 5

Thread: 5150 RACING: horrible Customer service / tuning

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    5150 RACING: horrible Customer service / tuning

    Was not able to post this back when this happened on this fourm but have a a few other EVO X forums already. I took my 2015 EVO X to get tuned at 5150 Racing on 9-20-19. My appointment was for 12pm (noon) After talking to Ian ( their sales guy ). I was going to purhcase there flex fuel kit ( which Jon didnt tell my Iphone cannot download the app since its Android system Bluetooth software ) , WALBRO 450 fuel pump, Terpha V3 software and get a flex fuel tune. I arrived at 5150 racing at 12pm. No one at the shop. I waited for about about 15-20 mins before Ian arrived. At that point he told me Jon was eating somewhere and offered us to go. Which i told him no and my appointment was at 12. So after waiting about an hour and a half. Jon arrives. He does not even greet me. Mind you i am the only customer there. I had to go up to him to start a conversation. Jon thought he had a flex fuel kit in stock which he did not or a fuel pump. So he took them out of a customers car to install on my car So i use a used flex fuel kit and i think a new Fuel pump they took that from another customer project. After the tuning was done. Jon did not drive my car at all on the street and told me go ahead and take it for a drive. I do not live in this area. I did 2 light pulls and headed back to my hotel where i took my family down to LA for a trip. I did not get to test the car till i got back home which is a 4 and a half hour drive back north. Once i got back home i was able to do some real pulls and link gears together and found i had a huge fuel/ spark cut issues. Also my car is seeing 32PSI on the stock turbo. i emailed Jon and Ian on 9-23-19. I heard back from Ian asking for data logs but never heard from Jon at all which is the tuner. I asked a ton of questions and called the shop which i never got a call back from Jon. I got the logs done and emailed on 10-8-19. After all my questions i asked Jon finally replied to my emails "ill check out the logs" that was it. NOTHING else. He never answered any on my questions. Jon emailed me back on 12-2-19 with an updated map. I flashed it to my car and the car still has the same issues as well now the car while driving is going lean and WOT AF are 13s. I emailed jon again on 10-10-19. Jon did not write anything back to me at all or say another about the logs i sent him. He sent me a blank email with a new map. Still the same issue i had with cruising and linking gears hitting this huge spark cut. emailed Jon again on 10-12-19. He replies on 10-19-19 stating there are issues with the V3 ROms and having this spark cut issues and we was going to send me a new ROM and questioned if my fuel pump that he sold me was bad. So this has been now 2 MONTHS since my car left his shop and the issue was not solved at all. I contact my bank and disputed the charge Since i was trying to call and email Jon and it hard to get a hold of him ( see other reviews with the same issues i have ) The bank asked me to contact Jon which i tried to do for him to make it right and he has yet to respond to me. I would never suggest anyone to go to his shop at all from the customer support Him or his employees offer paying customers. No i have a car that is not tuned correct and i have to pay again for a different tuner. I also did not mention i paid $400.00 cash and $650 on my debit card. i was going to eat the $400.00 cash but i feel he needs to refund me most of the tuning fees. Take your car somewhere else and read the review before contacting this shop. Jon is not a man of his word and very disappointed with his customer service for not trying to help me out when i asked so many questions to try to fix the issue before contacting my bank. Not sure if the bank will help at all. Even if i don't get my $650 back i guess my loss can be another customers gain to not take there car here for issues with this shop. Seeing all the other reviews On yelp on there customer service. Sad Jon did not want to help at all.

  2. #2
    Canyon Racer nicklulu's Avatar
    Join Date
    May 2006
    Location
    San Diego, CA
    Posts
    2,317
    Cars
    06 MR to 10 MR to 18 Focus RS, 09 Sarao GT-K (k for Karabao)
    Sorry to hear that bud.
    R.I.P. Sammy: http://www.socalevo.net/index.php?option=com_smf&amp;Itemid=37&amp;topic=1 21610.msg8407077#msg8407077<br /><br />Mobile Wheel Repair in San Diego: MZM Rimshine: http://www.socalevo.net/index.php?option=com_smf&amp;Itemid=37&amp;topic=8 8447.msg7802233#msg7802233<br /><br />Good price for parts: http://www.socalevo.net/forum/index.php?topic=97342.0

  3. #3
    it does suck and i did find out the tune was messed up causing the issue And once i got tuned from another shop i had no more issues and the car is running perfect without changing any parts. I just hope this spreads and no one goes to Jon or 5150 anymore.

  4. #4
    Canyon Racer nicklulu's Avatar
    Join Date
    May 2006
    Location
    San Diego, CA
    Posts
    2,317
    Cars
    06 MR to 10 MR to 18 Focus RS, 09 Sarao GT-K (k for Karabao)
    Hey, thank you for posting it.
    R.I.P. Sammy: http://www.socalevo.net/index.php?option=com_smf&amp;Itemid=37&amp;topic=1 21610.msg8407077#msg8407077<br /><br />Mobile Wheel Repair in San Diego: MZM Rimshine: http://www.socalevo.net/index.php?option=com_smf&amp;Itemid=37&amp;topic=8 8447.msg7802233#msg7802233<br /><br />Good price for parts: http://www.socalevo.net/forum/index.php?topic=97342.0

  5. #5
    Welcome. Glad I can spread the word.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •